Corrupted PDFs

Hi all,

I have a very weird problem with a few users where the PDF export from a very simple FastReport setup seems to get corrupted. For the majority of users (about 300) it works fine, but more of these problem users (4 so far) are cropping up.

The odd thing is that the characters displayed are the logical previous character from the set. 'B' becomes 'A', 'C' becomes 'B' etc. I've also noticed that it only seems to do it with Bold fonts. Fonts are not embedded in the report but I try to use one that I think will be on everyone's system - straight 'Arial' with DEFAULT_CHARSET. Attached is a small screenshot of the corruption. 'ANS' should read 'BOT' !

I got the issue initially with FR V5 so I downloaded the trial of V6 and still get the problem reported by the user. I cannot recreate the problem on my PC. I have tried a new VM installation of a Win 10 PC with just Adobe DC reader and it works fine in there.

Anyone got any ideas?





    i Am having this issue also.



  • 1.What version of FR do you use?

    2.What version of Delphi do you use?

    3.What version of Delphi do you use?

    4.Try to test compiled FR Demo on client computer with client prepared report (fp3)

    Is it generate wrong PDF too?

  • We also have the same problem. We are using Delphi RAD Studio Tokio.

    Is there any solution yet?

  • I generated a PDF Export with the compiled FR Demo and sent this to our customer with the problem.

    If I generate the PDF Export without the option "Embedded Fonts" the customer cannot read the pdf becaus of corrupted text (bold text is ok, normal Text is corrupted).

    Afterwards I generated a PDF with the option "Embedded Fonts = true". The PDF is shown corretly on the customers PC. Maybe this is the solution.

    Does anybody has the same problems? How did you solve this?

  • 1. Send your report template (fr3), prepared report (fp3) and result (pdf) to

    2. Send Arial.ttf from system where error is appear to

    3. What PDF browser, OS was used?

  • 4. Do you can to get described behavior on the your computer?

  • Tell your customer to disable Use local fonts option in the Adobe Acrobat reader settings (Ctrl + K)

  • Thanks for your reply. But this is not a very good solution. We now have feedback from several customers, that the pdf is corrupted. Of course, we can tell them to disable this option. But this is only a workaround because any other pdf which the customer receives from other suppliers does not have this problem.

    So I will send you the TTF from the PC where the error occurs and I hope that you have a better solution.


  • because any other pdf

    Send such pdf to

    But this is not a very good solution

    It seems this solution doesn't works

    Who can get wrong pdf on the own (not customer) computer?

  • Hello,

    today I was able to test this problem on a computer from our customer.

    The solution is not to disable "local Fonts" in Adobe Reader. The problem remains.

    But I found out that the customer has a Windows 10 BUILD 18362.1 (Version 1903) installed. With this version the problem occurs.

    After updating his Windows to a newer version (1909) and restart of Windows the PDF document can be shown correctly in Adobe Reader. So I think the solution is to install the newest Windows 10 Updates.

    Alternatively use "embedded fonts". But this will result in bigger pdf files.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.