Designer crashes when I save changes

When I try to save changes in Fast Reports Designer, I get this message:

Access violation at address 55E8DD7C in module 'frx28.bpl'. Read of address 00000004.

For example, I just tried to change my page numbering by changing 'Page' to 'Page#'. I cannot, because of the crash.

I have the source code. I can try to rebuild it if I know what to rebuild.


  • Try to completely uninstall FR and install latest build of FR VCL

  • I did a repair, but that did not fix the problem. The text for the repair option states:

    Repair installation errors. This option corrects any missing or corrupt files, shortcuts, or registry entries.

    If frx28.bpl was corrupt, repair should have fixed the problem. I am hesitant to remove & reinstall unless absolutely necessary.

    The crash only happens when I try to save changes to the memo field of a TfrxMemoView.

    I am working with .fr3 files that were converted from Quick Report using the Fast Reports converter.

    I can edit the .fr3 files with Notepad to make the changes as a workaround.

  • I uninstalled and reinstalled Fast Reports and the crash disappeared, but when I ran RAD Studio 11, I encountered several popup error messages because it was trying to load Fast Reports code from the 2024.2.4 folder and I had just installed 2024.2.6. I ran the Fast Reports repair option several times, changed the path in the environment variables from Windows and from RAD Studio, but I still got the error messages. I finally had to make a copy of the 2024.2.6 folder and name it 2024.2.4. That fixed the problem.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.