Installation Problem FastReport VCL in Delphi 11

Hi,

I have just installed the new Delphi 11 Alexandria (Enterprise) and did an install of Fast Report VCL 2021.2.1 (Date shown is 12 Jul 2021) from the GetIt Package Manager. The installation was OK and required a restart of Delphi. After the restart Delphi shows some error messages like this one here:


The message is in german but means in english "the procedure entry point could not be located". Any idea what to do?

Thank you - best regards - Andreas.

Comments

  • I have the same problem installing the FMX and the VCL libraries for CBuilder.

    Valeria

  • G'day Folk,

    I suspect there is a bit of a "lag" in getting the FastReport / FastCube / FastScript code "Delphi 11 Ready"!

    I've just checked our folders (we have FastReport Enterprise version 2021.2.8 installed), and there are no "D28" Files in the Source Folders, so there won't be any "D28" Packages.

    This is one of my gripes about Embarcadero, new releases never seem to come with GetIt up-to-date (this happened with 10.4.3 most recently). But I note also that the FastInRush Download Pages haven't been updated since early August (early July for FastCube), so perhaps I shouldn't blame Embarcadero this time

    Cheers, Paul

  • Good news Forumates! FastInRush has released 2021.3 with RAD Studio 11 support!

    See the Changes.txt file for details.

    https://cpanel.fast-report.com/download/111782

    Cheers, Paul

  • Hi, short update. I have now again downloaded the Fast Report VCL from the GetIt package manager (version date from 10th Sep.21) and now it installed it correct. I had only one small issue, after the restart of Delphi the components didn't show up in the tool palette. I had first to check them in the Packages section of Delphi (Components/Install Packages):

    After including these 4 packages the components show up in the tool palette.

    Andreas.

  • PolomintPolomint Australia
    edited September 14

    G'day Andreas,

    Glad it worked out OK for you. I note that GetIt is still saying (or was earlier this afternoon) that it will provide v2021.1 so that is a little odd. But the date on the entry was 10 September, so maybe the GetIt and FastInRush version control is different.

    I got our copy from the FastInRush Server (v2021.3) and have successfully installed it too, so we are both "happy"!

    Tschüss, Paul


    PS I am not 100% "Happy" - GetIt still doesn't have things we need (like the Jedi Component Libraries), so I won't be using Delphi 11 for our major Apps for a while yet! 😣

  • I too am looking for the Delphi 11 version, have Fastreport 6 professional license but it seems i can't download this version?

    Am i looking in the wrong place?

    The version on https://cpanel.fast-report.com/ is still 6.9.14 and is from July.

  • G'day Franky,

    You are in the right place.

    I suspect you are out of luck there. Did you not see the announcements six months back changing the licensing arrangements for FastReport Vcl? It is now subscription only, and v6.xxx is no longer being supported.

    https://www.fast-report.com/en/news/show/release-fastreport-vcl-2021/

    You need a v2021 subscription to get access to the Delphi 11 compatible code.

    If you have signed up for v2021 perhaps you have accidentally hidden the Product. Check your "Profile".

    Cheers, Paul

  • Thanks Paul,

    I'm afraid i missed those announcements, i'm just configuring Delphi 11 as a test on a virtual machine first before deciding to switch or not.

    So we need to upgrade from v 6 to 2021, i don't see a reduced pricing for update though, only the new license price of 399.

  • G'day Franky,

    As a fee-paying user too, I can't help you with "reduced pricing" 😏

    But I did see a link on the main page saying "Try it for Free". Perhaps that will allow you to do your evaluations without / at low cost...

    https://www.fast-report.com/en/product/fast-report-vcl/

    (Scroll down a fair way!)

    Cheers, Paul

    P.S. I understand that software pricing is a difficult thing to get right, and imagine FastInRush moved to "subscription" from "lifetime" licences because of cashflow problems, so I don't begrudge them that. But it would have been nice to have a reasonable transition period for us long-term (and regular licence updating) customers. 😉

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.