Hide Empty Data Row Fields

Hi, I have in my database some rows that do not contain texts, when previewing in fast report it appears to collect all empty rows and it combines it in one empty field of each category See screenshot - Report View attached. 

To get an idea of the issue see screenshot - Design View, see the red outlined box for location of the issue. 

However the issue is only when my data results in a text format, but when I have the data result as in digits-numbers there is a great option - See the red arrow to hide zeros, so when I have data as in numbers it is all good, but when my data results in a text I am stuck.

Please note the Sum still needs to Sum up all rows including the empty rows, it just needs to be invisible.

I would appreciate if there's any option or formula that can resolve the issue.



  • gpigpi Volnovakha, Ukraine
    edited April 20

    Show/hide objects from GroupHeader1 and restore/set to 0 GroupHeader1.Height in the GroupHeader1.OnBeforePrint event in the script depend of field's value

    procedure GroupHeader1OnBeforePrint(Sender: TfrxComponent);


    if VarToStr(<EstData."Proposal Description">) = '' then


    GroupHeader1.Height := 0;

    Memo28.Visible := False;

    Memo37.Visible := False;

    Line.Visible := False;




    GroupHeader1.Height := 25;

    Memo28.Visible := True;

    Memo37.Visible := True;

    Line.Visible := True;



Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.