Exception raised when attempt to Export to PDF after 6.8.3 / 6.8.4 Installed

Is anyone else having trouble with Exports to PDF, from the Preview Form, after updating to either of these versions?

We consistently get an Exception either by clicking the Export Button, or by attempting to Save to PDF, with the following Dialog Boxes either in the IDE or in the App itself:



From the IDE we have managed to trace the failure to frxBaseForm:


where it occurs somewhere in the FormCreate Method.

The "Changes.txt" file says that "DontEditInPreview" is deprecated, but we are not referring to this anywhere (in .pas / .dfm / .fr3).

<quote>[!!!] Changed behaviour of interactive objects. Restrictions -> [DontEditInPreview] is deprecated. Now all Text objects is disabled for editing in preview by default. To allow editing use Editable - [ferAllowInPreview, ferAllowInExport] for text objects (its impacts only text objects)</quote>

I reversed out the update and reverted to 6.8.2 and now happily get this dialog box displayed, before the exported PDF itself opens in Acrobat:


Any hints as to where I should start looking?


Cheers, Paul

Comments

  • gpigpi Volnovakha, Ukraine

    FR 6.8.5 works OK for me. Try it

  • PolomintPolomint Australia

    Sadly GPI, it does not work for me!

    But I'll keep the v6.8.5 installation on the one machine I tried, so I can create a test application to demonstrate the problem. It might take a day or so before I get to it.

    I hoped the Call Stack would tell me something, and even tried to step through the code "line by line" but didn't make much sense of it.

    Meanwhile, as I have now raised a Support Ticket, I'll send you the new details via that.

    Cheers, Paul

  • PolomintPolomint Australia

    SOLVED


    For some reason, yet to be determined, there are copies of frxRCclass.dcu and frxRCexports.dcu in our Application Folders. These are being rebuilt with the Project(s). So it looks like the Exception is caused by out-of-date code / incompatible interfaces. Solved by deleting the two Units, and rebuilding. Note that these are the only FastReport Units present (although there were some FastScript Units too).

    Now I have to work out why these two Units get rebuilt, and aren't just linked in from the %programfiles% Folders.


    Cheers, Paul

  • PolomintPolomint Australia

    OK, I have come back to this problem with "fresh eyes", and it is not "Rocket Surgery".

    The problem is that the installed FastReport (and FastCube) releases put everything into one folder. When you Build an application that references FastReport / FastScript (and / or FastCube), some (but not all) of the "Fast" Source Code gets rebuilt.

    The RAD Studio Tools | Options | Language | Delphi | Library settings point to the one folder (actually two different ones for Win32 and Win64).

    Because our major Application is already very big, and time-consuming to rebuild, we want to eliminate anything that doesn't need to be recreated.

    I have temporarily solved this by moving all *.pas files from the "one folder" to new sub-directories I've called ".\Src".

    Works perfectly.


    We can't be the only people who have this problem! When I get a chance, I will write up how this fix could be made permanent with changes to the "DCCnn.exe" Command-line compilations used by "Fast" Recompile.exe.


    Cheers, Paul

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.