Error missing DLL fs26bpl

Hello,

after installing new version FR6 prof (fr679allpro.exe) for Delphi 10.3 and 10.4 the Delphit 10.4 works fine.


But wenn starting Delphi 10.3 i get an error that the DLL 'C:\WINDOWS\SYSTEM32\fs26.bpl' was not found. After clicking 'ok' then next message is "Package C:\Programm Files (x86)\FastReport 6 VCL Professional\LibD26\dclfrx26.bpl is missing"


First error:


second error:


what can i do - especially my 10.4 is working fine!


sorry for my bad english!


best regards

Rolf

Comments

  • PolomintPolomint Australia

    G'day Rolf,

    Your English much better than my German / Deutsch!


    When you installed the latest version did you:

    • first uninstall the previous version?
    • delete all traces of FastReport and FastScript from the system folders?
    • install the latest version on a "clean" system?
    • run the Recompile.exe routine against all of your Platforms (10.3 and 10.4)?

    Unfortunately with the current FR Installer you cannot "update in place".

    It may be sufficient to run Recompile.exe (in the <programfiles>\FastReport 6 VCL <Edition>\ against 10.3 (32-bit and 64-bit).

    Frustrating, I agree.

    Tschüss, Paul

  • roklirokli Germany

    Hi Paul,


    thanks for your information!

    First try was to recomplie - but it dosn't work.

    Next try: i have not done the second point in your topic list and therfore i uninstalled the complet version 6 und delete all directory entries called "fastReport". Then i also delete the regestry entry called "FastReport".

    After installation is the same behavior: Delphi 10.4 works and Delphi 10.3 don't work. Another interessing point: Now the error message shows another dll (somthing like ADO*.bpl) missing.


    Now i will search for other information about the problem. If i get an suggestion, i will wirte down it here.


    regards Rolf

  • PolomintPolomint Australia

    G'day Rolf,

    Another "lateral thought".

    Have you checked the Library Paths on both 10.3 and 10.4 installations?

    I have a vague memory of a problem when we upgraded from FastReport "Professional" Edition to "Enterprise" that there were old directories present, and they caused problems (sadly I didn't make a record of it).

    On a system with an English set-up you get there from the IDE with menu option Tools | Options and then expand Language > Delphi > Library and look in:

    • Library path
    • Browsing path

    for both Win32 and Win64!

    The error you are now getting with "ADO*.bpl" is very odd. I can't think what caused that from what you did.

    Hope that is helpful.

    Tschüss, Paul

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.