Class TfrxDataPage not found

Attempting to use the latest Emb VCL version in 10.4 generates a TfrxDataPage not found error. This same report (without any changes) worked just fine in the 10.3 version with the older component set available at that time. Adding a new "hello world" report (just a single page with a text memo) also generates the same error. The report opens fine in the designer, its only at runtime that the error is generated.

Comments

  • Additional information that might help. The report is part of a datamodule that gets created at runtime, it is in the creation of the datamodule that this is occurring. The datamodule does have the {%CLASSGROUP 'Vcl.Controls.TControl'} in the implementation. Reinstalling the pro version of the components had no impact.

  • gpigpi Volnovakha, Ukraine

    Create small demo project with error and send it to support@fast-report.com

  • Discovered the problem. My VCL project had a reference to a unit which was including FMX controls. Correcting the reference to point to the proper VCL.Controls corrected the problem with loading reports at runtime.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.