Problems with version 6.2.1 and Delphi 10.3 Rio

CGPCGP Canada
edited 2:14AM in FastReport VCL 6
My programme initially compiled in Rad Studio 10.1 Berlin Architect version using FastReport 5.
Purchased upgrade and downloaded 10.3 Rio then went into GetIt Package Manager and downloaded FastReport 6.2.1.
Tried to compile existing programme into 10.3
Received error message "Unit fs_iinterpreter compiled with a different version of fs_isysrtti"
I uninstalled FastReport 6.2.1, took all calls to FastReport out of the programme and recompiled.
Programme now running in 10.3
Tried to reinstall FastReport 6.2.1 through GetIt Package Manager but it says it is already installed even though I have uninstalled it.
FastReport is gone from c:\program files.
Went into Windows 7/Control Panel/Programs and Features to see if any of FastReport was still there.
Found nothing.
GetIt will not allow me to reinstall another copy of FastReport.
Not sure where to go from here. Any suggestions?

Comments

  • RMBRMB
    edited June 10

    I have the same Problem with FR and 10.3 but i have a Litence for Standard Edition,


    What can i do to solve the Problem?

  • PolomintPolomint Australia

    I don't know if it will help you, but in the past we've solved FastReport / FastCube upgrade problems by first Uninstalling existing versions with IObit Uninstaller.

    You can get a free / evaluation copy from IObit. It cleans out the stuff FR uninstall leaves behind.

    Then do a fresh Install.

    Cheers, Paul


    PS We now use an Administrator Utility we wrote ourselves to automate the Uninstall / Install / Recompile so IObit is no longer necessary for us...

    PPS I have no links to IObit (apart from being a happy licensed client) and offer this suggestion independently!

    P

  • Sorry P it doesn't work.


    Uninstall with IObit and new install doesn't help...


    Alwas the same error :

    [dcc32 Fataler Fehler] fsisysrtti.pas(625): F2051 Unit fsiinterpreter wurde mit einer unterschiedlichen Version von fs_isysrtti.TfsSysFunctions compiliert


    Any idea?

  • PolomintPolomint Australia

    Hmmmm. Looks like there are Fast Script packages / units lurking somewhere on your system.

    Have you tried a file search for fs.DCU / fs.BPL? If after Uninstall there are any there, a manual delete is your only option.

    You might have leftovers from a previous version. Or (as we have seen sometimes) "Fast" Units get compiled to an application location (but you have the Std Licence so that might not happen in your case).

    Alternatively, have you tried to run Recompile.exe to force everything to be replaced?


    Tschüss, Paul

  • PolomintPolomint Australia

    Oh the "search for fs.DCU / fs.BPL" should have included wildcard characters but the new Forum software won't let me include them. But of course you realised that was what I meant didn't you?

    😉

  • You can use everything to search for anything fast report (https://voidtools.com)

  • gpigpi Volnovakha, Ukraine

    Uninstall FR, install it again, remove all pas files from FR's LibDXX folder, run FR's recompile.exe and recompile all FR's packages

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.